Help

rene ramirez

Member
Nov 13, 2012
25
33
0
71
Weatherford, OK
@ClendonRoss

Clendon - I haven't been able to access the premium boards since last Wednesday.
My credit card hasn't expired.......cleared cookies/cache........logged out and logged back in.
Even tried renewing my subscription, but I keep getting an error message asking for the first name on the credit card.
There is no first name.......only an initial, my middle and last names.
Sent a message to the help desk, but guess they're busy......haven't heard anything from them.
I get this message when I try to access premium


Upgrade required
An account upgrade is required to continue.
 

canid

Member
Jun 5, 2012
25
6
0
@ClendonRoss

Clendon - I haven't been able to access the premium boards since last Wednesday.
My credit card hasn't expired.......cleared cookies/cache........logged out and logged back in.
Even tried renewing my subscription, but I keep getting an error message asking for the first name on the credit card.
There is no first name.......only an initial, my middle and last names.
Sent a message to the help desk, but guess they're busy......haven't heard anything from them.
I get this message when I try to access premium


Upgrade required
An account upgrade is required to continue.
Same issue here
 

RJHookEM90

Member Who Talks
Dec 16, 2009
723
84
0
Islamorada, Fl
I’m having this same issue, haven’t had access to premium forums for a week now. Tried the steps listed in the pinned thread and I’ve been unable to get anywhere. I emailed insidetexas’ help page, and pm’d @ClendonRoss But have not heard back yet. Please help!
 

SAhornfan

Member Who Talks (A Lot!)
Oct 29, 2008
33,591
29,648
0
San Antonio, TX